Saying issue with payment info on a free match

I am trying to register for a free match and it is saying there is an issue with the payment but I cannot put any payment methods in.

This is the same with our free match

image

https://practiscore.com/clubs/north_arm_pistol_club_ipsc

Hi @Tylor_Jakino and @Rod_McLean,

We did a special post last week regarding using the bypass payment link, which is preferred for free shooters. Hope this helps.
Storefront Updates/Best Practices/Thoughts from the PS Team

Our club matches are all free. So the match setup is selected for “offline” payments, and the price $0. This worked until today when all registrations are now having this same error.“There was a problem with your payment amount”.
I tried cloning a match and also creating a new match from scratch. The error still persists.
We are located in Australia. I noticed the other club was also Australian.

1 Like

Thank you for the response
Can you please assist me pleas as I am not great with this stuff

We have this match set up to shoot on Sunday
https://practiscore.com/napc-ipsc-19-07-220/register
We don’t have stripe nor do we want to charge anyone via PractiScore at this time
Could you please have a look at how I have set this up as I have used $10 fee and a $ 10 discount by put ideally I would rather leave all mention of fees out of the PractiScore booking process
Can you please help me here as all our matches are free and this is a live match with registration open and shooters can self squad

Regards

Rod McLean

We pushed out a fix for this earlier this morning. Please let me know if you continue to experience this issue.

Hi @Rod_McLean,

I just went and registered for your match and was able to register.

I think @Jeff_Krammer fixed this earlier today.

Hi @ Stephanie

Thanks but it still has the $10 i added to make it work
could you please check my settings i am wanting it to be $0

the $10 shows in the registration page
i am wanting to be a free match

Just saw @Jeff_Krammer comment and will adjust it and check

@Rod_McLean,

Try going into your individual match page and change to the following settings. This should help

2 Likes

@Stephanie yep you nailed it thank you so much

1 Like