PS ID Lookup Not Finding

I created a match on my app, and when I tried to lookup the PS ID for the club using the admin email associated with the club it does not find anything. First timer tying to get our sportsman club up and running. Any help is appreciated.

The first question to figure out what is happening is…
Are you the owner in PS of the Ohio River Valley Council club?

Have you looked at the tutorials in the support section of the web site?
I suggest you go through this and hit the tutorials.

What tablets are you running???

Another suggestion is when you create a match to use the name of the club ie.
“Ohio River Valley Council IDPA June, 01 2020” , not a generic name.

Ok, I might have left out some key info out. Yes I in fact am the owner in PS for the Ohio River Valley Council club, and I am able to search for that club when trying to upload match data. What is happening is that I am assisting another shooting friend that is trying to make the jump to using PS. When we try and look up his admin email, nothing returns for that. I have tried to delete the club and recreate the club that he has control over, but to no avail will the search populate anything from the “scoring” device.

Would you consider having him read all the tutorials?
I will need to be in touch with him to work on his problem. From the sound of things we will have to clean up all his accounts first. He can PM me here at the community if he wants.

I’m confused. is PS ID lookup referenced in the original question and topic title were done in iOS app or on the web site?

I have not heard from anyone to help clean up the accounts…