Occasionally can't create a new match

Every now and then, and today is one of them, I go to create a New Match and after filling out all the required fields when I go to click on Create Match and after a couple seconds the registration page has been cleared and the match hasn’t been created. After the 1st time I thought Ok forgot to fill something out, after the 3rd time I’m like no I had everything filled out.

I create matches on the same computer and other times it creates the match 1st time and sometimes it will the next day. Am I missing something? I was also thinking it would be helpful if you did miss a required field that when you hit the Create Match it would highlight that required field to fill out. If it does that already it’s never done it for me so maybe a setting??

Thank you for your help.

Based on your description I have to suggest that your device is caching the old web page and you don’t see the current one until the page is refreshed.
Try refreshing your web page after creating the match.

Thank You DJ. I refreshed the screen, filled out the registration form and it wouldn’t go. Refreshed again , forgot to put in number of shooters (which showed me that so i know that works) then it took the match. Tried creating another match and it wouldn’t go, said to heck with it and tried it in Chrome versus Edge and it wouldn’t go. Tried it again and it went through.

After thinking about this i occasionally had the same issue on my old laptop and even being on a different network. Definitely has me baffled as to why it won’t pick up that page. If anyone else has had the same problem I’m open to suggestions.


Did you do a “cache bypass” refresh?

No I haven’t but will give that a try.
Thank You