Issue with bluetooth timer (Pro Timer BT) and Amazon Fire 8

We just ran our first match using a set of new Pro Timer BT’s and our usual Amazon Fire 8 tablets running version 1.7.18 of the PractiScore app. When the timer is first turned on and then synced with a tablet, it was working fine, however over time (which differed for each tablet) there would start to be a delay after hitting the timer icon (2 or 3 seconds) where it would say ‘Getting Time’ and then would just stop working until the timer was turned off and then on again, and then re-synced with the tablet.

The Pro Timers have the latest firmware from CE. Tablets are all HD8 2017 or 2018 models.

Any tips for getting this to work better? Thanks in advance.

Jeff

I’ve put several fixes related to that in the last few app releases and observed improvement. Though it previously been focusing on the “connection” part of the interaction.

So, I need more details:

  • what “over time” really was? minutes, hours?
  • or how many shooters scored over what period of time before you start noticing issue?
  • is timer connecting fast all the time (the timer icon is not stricken through)?
  • and the issue is observed solely when tapping “pull time” on the not stricken through timer icon on the scoring screen?
  • was tablet always been on, or it was going into sleep while on the scoring screen (e.g. turning screen off)

The issue was always observed when tapping the icon to get the time for the String (Steel Challenge match). One other thing I remembered, when it starting pausing showing the ‘Getting Time’ message … sometimes the scorer would start entering the time manually thinking it wasn’t going to return the time (even after waiting 5 or more seconds), and the time would suddenly then pop-up and fill in the field (overwriting what they were entering manually, or filling in the next String field if they already moved to the next string).

For a couple of the tablets, it happened fairly soon after the sync (2 or 3 shooters in on the first squad - it would start the delay and then would just stop working). One of the tablets didn’t start acting up till after the 3rd squad went through. It also wasn’t consistent where it would happen on a certain string for a shooter, sometimes it allowed a couple strings to be recorded then started pausing, sometimes it happened on the first string. The timer icon never gets the stricken through icon, and it’s still showing when accessing the timer drop-down option - however, once it got into this mode, the second string of characters that show up under the timer info when it’s connected(i.e. S21 E0.11 V100 20211223) would disappear.

This was happening while the tablet & timer was active/on - neither had gone to sleep yet.

The timers also connect quickly when restarted. Restarting the app also re-connected the timer instantly.

Anything noticeably different between these tablets?
E.g. 2017 or 2018 model or the version of FireOS on them?

Also, does your range where this is happening has wifi with the internet access?

I’ll poke around to see if I could replicate issue here. It may take some time.

The tablets are running at 5.6.9.0 of FireOS (or latest version, I just updated them all for the start of the season). I did not get a chance to notice whether 2017 or 2018 models were worse or better, we have a mix of them and all the tablets we used yesterday eventually exhibited the behavior.

The range currently doesn’t have wifi up (we usually do but it’s not working at the moment).

I’ll also try to see if there’s a way to get it to happen more consistently to give you more information. I have one of the tablets and timers on my desk here and was just messing around with it and I got it to happen in the middle of recording strings for a competitor, so I restarted the app, timer reconnected now I can’t get it to happen again.

Also we have one HD 8 that’s a newer 2020 version, I plan on trying to see if it works any better with the newer model this weekend.

Quick update - I tried a couple new Fire tablets (2020 version) - which worked better at first, but then they eventually lost connection with the timer also. When the connection is lost, either the tablet needs to be powered off and powered on, or Bluetooth cycled off/on before the app will pickup the timer again.

1 Like

Would be interesting to hear if the problems I’m having with the Bluetooth are unique to Fire tablets, Android tablets in general - or the new Pro Timer BT if anyone else has any of these combinations currently.

@Jeff_Maher I’ve got swamped at work and haven’t got time to take a deep look into this. The steps to replicate issue would really help.

In the meanwhile please email at [email protected] with email address for you Google Play app store. I’d like you to try something to see if you experience the same issue wit that too.

PS: You can get the Google Play installed on Amazon tablets too. See details at Tablet recommendations for the PractiScore app for Android

@Jeff_Maher BTW, there were several timer firmware updates since your’s 20211223 one.

I’d suggest to update to the latest firmware using timer’s “PT Link” app and also do a factory reset for the timer (holding the “start” button when powering up the timer).

I’ll email [email protected] - we have Google Play app store install on all the tablets.

I have installed version 1.1 of the firmware, that appears to be the only one available to me using the PT Link to upgrade the timers, and the datestamp you’re showing in the last post is definitely newer than that. I may have to call CE to see why I’m not seeing a later version of firmware.

Hi, we just used CE Pro BT timers with the current version of PS for Android for a match yesterday. We used Lenovo tablets with Android 10. Our CE Pros are running firmware V 1.2.

After a few shooters, we got the clock icon with the line through it, and could not get the time from the timer via BT.

I was on a different squad using the same kind of Tablet, but using an AMG Commander BT timer. It worked most of the match, but I had to intermittently turn the timer off and on, as it too got the clock icon with the line through it.

So, it appears it is not just Fire tablets, and not just CE Pro BT timers that are having issues.

From the Timer selection screen, it always appeared as if the timers were connected, even when we got the clock/slash icon.

Doing more testing this week.

@Martin_Frandsen in the PractiScore app for Android the timer is only connected when you enter the scoring screen and it is disconnected when you leave scoring screen. The timer selection screen can connect to the currently selected timer in order to retrieve the current timer settings and it also disconnects from the timer after you close the timer selection screen.

The issue @Jeff_Maher described seem different, as he is able to connect, but the timer retrieval is gradually increases over time. I have some ideas why that could be the case, but I am still unable to replicate conditions when the app gets into that state here.

I need to get some better idea about how you guys are using timers with the app. Basically I need to know everything that is happening between shooters in as much details as possible. For example:

  • how long does it take
  • what happens with the timer and tablets (does either of them goes to sleep)
  • are the timer and the tablet always in range or timer goes far away from the tablet during stage runs or scoring

@Jeff_Maher I haven’t seen email from you. Not sure if it was lost