Failure to Sync with Andriod and Ipad Devices

Sync devices is failing between devices on a previously working wifi network.
It is failing from Apple to Android, Android to Android, Android to Apple.
Apple software is V 1.732
Android is V 1.6.51

I took the 4 scoring devices home and added them to my home network, same problem.
The firmware at the range was updated just prior to the issue. My home firmware on my ASUS RTAC-88U was also recently updated on 12/11/20. (v2.208) No peer communication.

I moved the devices to an old network that has only TIVO devices and the Sync works properly.
It appears that the most recent firmware is disabling the peer to peer communication over the high ephemeral ports that the Practiscore app uses.

Any idea how to fix it or why it is happening? If this is the result of a security update that is hitting commercially available routers, this may become a larger issue quickly.


@Andy_Feigin check in your Wifi router settings the “client isolation” mode/option is disabled.

That’s the first thing I checked when I noticed the problem. It’s not even an option and I can communicate with other hosts on the network using ping, SMB, ftp, etc.

Another thing to check is that “location services” are enabled on Android devices (probably on iOS too) and then verify that PractiScore app has permission to access location in the system settings.

Do you see wifi access point name at the bottom right of the scree in Android app?

Can you also ping these tablets on your wifi network? Long tap on the “sync code” in PractiScore app for Android will show you a network diagnostic info with device ip address.

Location services was disabled on one Android and not the other Android. Enabled it, now I see the SSID on both, no change to the sync ability.

Yes, they are pingable by the IP shown. Also able to telnet to the IP over tcp 59613 which is the IP shown on the config.

So, with location services enabled on Android tabled and location permission enabled for PractiScore app for Android, can you sync Android to Android?

  • clear all devices you see on wifi sync screen, tap Refresh and wait until it completes. Did it find any devices?
  • if it did - does sync work?
  • if it didn’t - try to manually enter sync code from another Android device and see if sync worked?

BTW, what Android devices are those and what version of Android? also, does your wifi network has internet access?

With location services enabled, I can see the SSID in the lower right. Android to Android fails on the range’s network. When I move the tablets to a very old Linksys router, all syncing functionality works perfectly. Also works from Ipad to Android on the Linksys router.

On the range’s network, no devices automatically populate, syncing fails even when entering the sync code manually.

Both networks have internet access, not sure of the tablet versions as they’re back at Rio.

Still seem to be missing responses and things to try on some points above. Some of the things need to be checked on your range network and devices connected there.

Generally, if you can ping or telnet to device on the same wifi (there are apps you can install on Android devices to do ping, etc), I can’t think why sync won’t work (it does pretty much the same).

Unless there is some kind of VPN or antivirus software installed on your tablets that is preventing connection. Otherwise maybe there is a networking issue, e.g. range extenders that give your tablet different ip namespaces or “client isolation” option is enabled on wifi network.

  • When sync doesn’t work, what error are you getting there?
  • I presume it doesn’t work even when you manually enter the sync code?
  • What network info do you see for that wifi from PractiScore app for Android using the long tap on the sync code on the main app screen on both tablets?

This has worked for me every time I had sync errors. When I change networks I just do this first and it has resolved my issues.

1 Like

Still can’t get them to sync on the wireless networks with updated firmware. Works perfectly on older wireless routers and all devices show up on a scan.

@Andy_Feigin given that it does work on one network but not on the other, I strongly suggest to look at that other network configuration.

Verify for any restrictions on device to device communication, including device to device visibility, port filtering or any protocol restrictions. You may need to find an experienced networking engineer for that.

As an alternative, get a portable battery-powered wifi hotspot or use wifi hotspot on your phone as an emergency or backup hotspot for syncing.

Eugene, I sometimes have the same issue, with mine They will sync when we are getting ready to send the tablets out to start the match, after the match is score is when I get the fail to connect with just one or two of my tablets. The last match on 12-20 4 out of 5 would sync back to the master tablet and one would not sync to any of the others, tried clearing all sync devices, manual enter, turn off and restart, finally after 2 hours it would finally sync. This was using two different wifi/networks one at the range and one at my house. The only thing different that I can think of is one squad uses the new AMG timer and is synced to one of the tablets they are using and I believe that is the one I have these issues with. Could that have any effect on this, I wouldn’t think it would.

@mark_chapman short answer - I need more data.

The common problem with all reports related to sync issues is that you guys are trying to guess what is happening and/or want me to guess it for you with a little or no specifics. On top of that, you are trying to guess what was happening some time ago, without having access to your network environment and devices.

For any of sync reports I need at least the following:

  • information if your wifi network has access to internet or not
  • Android version on each device and version of the PractiScore app
  • location services enabled on device or not and location permission is granted to PractiScore app or not
  • for each device refusing to show up on a sync screen after refresh or sync with a manually entered sync code - need the network info details (long tap on sync code on the main app screen or on “Pull From Device” on the sync screen)

PS: I don’t think Bluetooth connectivity is related, other than having a different PractiScore app version and/or different system settings related to location services or permissions between those devices.