PractiScore apps hardware requirement

As of June 2024 we don’t recommend purchasing Apple devices that can not run iOS/iPadOS 17. For supported Apple devices see iPad models compatible with iPadOS 17 - Apple Support (CA)

For Android devices devices below Android 9 are NOT recommended.

For Amazon tablets. FireOS 8 and prefer the latest generation devices (e.g. 2022 or newer). They are often on sale. Fire 10, Fire 8, Fire 7.

Current bare supported minimums. We may have to bump them up in the near future

  • Android 5
  • iOS 13
1 Like